Creating a new SSL certificate on the First Node

Because the FQDN used to access the Client Access servers in our NLB cluster doesn’t match
the FQDN specified in the common name field nor the subject alternative names field in the
default self-signed SSL certificate that automatically is installed on each Client Access server
during Exchange 2007 setup (Figure 3.5 and 3.6), we must create a new certificate.
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Figure 3.5: Subject Alternative Names on CASO01 Certificate Property page

[ Machine: CAS01 | Scope: ehlo.dk

[PS] C:\O>Get-ExchangeCertificate | FL

AccessRules : {Systen.Security.fAccessControl.CryptolevAccessRule, Systen
.Security.fccessControl.CryptoKeyAccessRule)
CertificateDomaing : (CASO1, CASOL.ehlo.dk)
ivateKey : True
: True
: CN=CASH1
: 27-96-2008 99:26:20
: 27-86-2007 09:26:20
PublicKeySize : 2848
SerialNunber : B97EBSBSD3IB158A14DA47DS ESABEAZBS
Status : Ualid
Subject : CN=CASHL
Thunbprint : CEBYD1DO6HBGABABIBS 349200 E462713479A3BS

Figure 3.6: Subject Alternative Names on CASO1 via the Exchange Management Shell



For the purpose of this article series, we’ll generate a new certificate using an internal
Microsoft certificate authority server, but in a corporate production environment, you would
in most situations want to submit the certificate request to a 3rd party certificate authority.

Note:

Because we need a certificate in which multiple FQDNs have to be specified, we must use a
subject alternative name (SAN) certificate. At the time of this writing only a handful 3rd party
CA:s offer these types of certificates, most of which are listed in the following KB article:
http://support.microsoft.com/kb/929395.

As we’re going to generate a request for a new SAN certificate, we must use the New-
ExchangeCertificate cmdlet for this purpose, as the IIS Manager isn’t capable of creating
requests for SAN certificates. To do this launch the Exchange Management Shell, then type
the following command (replace the names with your own):

New-ExchangeCertificate —GenerateRequest —SubjectName “C=dk, O=EHLO organization,
CN=mailehlo.dk” —DomainName mail.ehlo.dk, autodiscover.ehlo.dk, casO1.ehlo.dk,
cas02.ehlo.dk —FriendlyName “CAS SAN Certificate” —KeySize 1024 —Path
c:\CAS_SAN_cert.req —PrivateKeyExportable:$true

After hitting Enter, the thumbprint for the new certificate request will be listed as shown in
Figure 3.7.

# Machine: CASO1 | Scope: ehlo.dk T =10} x|

[PS] C:\O>New-ExchangeCertificate ~GenerateRequest -SubjectName ‘““'C=dk. O0=EHLO org

anization, CN*mail.ehlo.dk" ~DomainName mail.ehlo.dk, autodiscover.ehlo.dk, casVgs
l.ehlo.dk,. casB2.ehlo.dk ~FriendlyNane "CAS SAN Certificate" ~KevySize 1824 ~-Path
c:\CAS_SAN_cert.req -PrivateKeyExportable:S$true

Thunbprint Services Subject

129BESC?748954D2B6BEAZ2CF21341 FBF408061 D38 CN=pnail.ehlo.dk, O=EHLO...

[PS1 C:\>

Figure 3.7: Generating a request for a new SAN Certificate

Submitting the SAN Certificate to a Microsoft Certificate
Authority

With the SAN SSL certificate request generated, we can submit it to our Microsoft CA, or
almost that is. The reason | why | say so, is because by default a Microsoft CA cannot handle
certificates with the SAN field properly. To fix this issue log on to the Domain Controller and
open a command prompt window, then type the following command:

Certutil —setreg policy\EditFlags +EDITF_ATTRIBUTESUBJECTALTNAME?2

After hitting Enter, you should see the old and new value as in Figure 3.8.
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Figure 3.8: Changing the EditFlags on the Microsoft CA

Now restart Certificate Services (CertSVC) service on the Microsoft CA server (Domain
Controller) in order to have the changes applied (Figure 3.9).
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Figure 3.9: Restarting the Microsoft Certificate Service

We’re now ready to submit the certificate request to the Microsoft CA. One way to do this is
to open a browser and type http://dc_name/certsrv. On the Welcome page, click Request a
certificate (Figure 3.10).
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Figure 3.10: Microsoft Certificates Welcome page

On the Request a Certificate page, click advanced certificate request (Figure 3.11).
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Figure 3.11: Requesting a Certificate




On the Advanced Certificate Request page, click Submit a certificate request by using a
base-64-encoded CMC or PKCS #10 file, or submit a renewal request by using a base-
64-encoded PKCS #7 file (Figure 3.12).
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Figure 3.12: Selecting the second option on the Advanced Certificate Request page

Now paste the content of the certificate request file into the Base-64-encoded window as
shown in Figure 3.13. Then select Web Server in the certificate template drop-down menu
and click Submit.
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Figure 3.13: Submitting the Certificate Request

The certificate has been issued and you can download a DER or Base 64 encoded version by
clicking Download certificate or Download certificate chain. Let’s select Base 64 encoded
followed by clicking Download certificate chain (Figure 3.14).
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Figure 3.14: Downloading the issued Certificate

It’s time to import the issued certificate using the Import-ExchangeCertificate cmdlet. We do
this by typing the following command:

Import-ExchangeCertificate —Path c:\certnew.p7b

The certificate has now been imported to the personal certificate store.

# Machine: CASO1 | Scope: ehlo.dk e

[(PS] C:xOlnmport-ExchangeCertificate ~Path c:\certnew.p?b

Thunbprint Services ENTUR A

D3DB7858F9249CBFECIA262871D54A25CAEC391B CN=mail.ehlo.dk., O=EHLO...

[(PS) C:\>o

Figure 3.15

To verify the certificate looks like expected, let’s now type the following command:

Get-ExchangeCertificate -Thumbprint <thumbprint> | FL



% Machi

[PS] C:\OGet-ExchangeCertificate

Thunbprint Ser “es Subject

DIDB7858F9249CBFB8C3IN262871D54A25CAEC3918 CN=mail.ehlo.dk. O=EHLO...
CEB9D1DB6BB66BABIBS34920A9E462713479A3BS . oo CN~CASH1

[PS] C:\OGet—-ExchangeCertificate ~Thunbprint D3ID87858F9249CBFBCINZ262871D54A25CHE
C391B | FL

AccessRules : {System.Security.ficcessControl.CryptoKevAccessRule, Systen
Security. AccessControl.CryptoKevAccessRule)
CertificateDomains ¢ {(mail.ehlo.dk, autodiscover.ehlo.dk, cas®l.ehlo.dk, casBh2.
ehlo.dk)
HasPrivateKey : True
sSelfSigned : False
N : CN=EHLO Root CA., DC=ehlo, DC=dk
s B6-2889 13:18:83
: 27-96-2007 13:10:83
: : 2848
SerialNunber : 619C66 D1 BBBANOBBAMG
Status : Ualid
Subject : CN*mail.cehlo.dk, O~EHLO organization, C~dk
Thunbprint : D3DB785BF9249CBFBC3A262871D54A25CHEC3918B

(PS] C: oo

Figure 3.16: SAN Certificate - Detailed Information

Finally we need to enable the certificate for the client services, our end-users will use to
connect to their mailboxes. In this setup I’ll enable the certificate for OWA, EAS, Outlook
Anywhere, POP3 and IMAP4. To do so we need to type:

Enable-ExchangeCertificate —~Thumbprint <thumbprint> -Services “IIS, POP, IMAP”

GMMNW CASO01 | Scope: ehlo.dk _ =10] x|

C:\>Enable-ExchangeCortificate ~Thumbprint D3ID87858F9249CBF8C3IA262871D54A25
Services “I1IS, POP, IMAP"

Figure 3.17: Enabling the SAN certificate

The certificate has now been enabled for these services but only on the first Client Access
server in our NLB cluster.

Importing and Enabling the SAN SSL certificate on the
Second Client Access Server in the NLB Cluster

To import the SAN certificate on the second Client Access server in the NLB cluster, we first
need to export it from the first Client Access server. When doing so, we need to make sure we
export the certificate with its private key. This is done by opening the Certificates snap-in. To

open the Certicates snap-in, click Start > Run and type mmc.exe to first open an empty

MMC window. Now click File > Add/Remove Snap-in > Add > Select Certificates > Click

Add > Select Computer Account > Click Next > Finish > Close and finally OK. Expand
Certificates (Local Computer) > Personal, then right-click on the certificate that should be
exported. On the context appearing menu, select All Tasks > Export (Figure 3.18).
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Figure 3.18: Selecting Export on the Context Menu

In the Certificate Export Wizard, click Next. On the Export Private Key page, select Yes,
export the private key as shown in Figure 3.19 then click Next.

Certificate Export Wizard : x|

Export Private Key
You can choose to export the private key with the certificate,

Private keys are password protected. If you want to export the private key with the
certificate, you must type a password on a later page.

Do you want to export the private key with the certificate?

% ¥es, export the private keyi

" No, do not export the private key

< Back l Next = I Cancel

Figure 3.19: Exporting the private key



On the Export File Format page, select Personal Information Exchange — PKCS #12
(.PFX) and tick Include all certificates in the certificates path if possible as shown in
Figure 3.20. Click Next.

Certificate Export Wizard B x|

Export File Format
Certificates can be exported in a variety of file formats.,

Select the format you want to use:
€ DER encoded binary %509, CER)
€ Base-64 encoded ¥%.509 (, CER)
" Cryptographic Message Syntax Standard - PKES #7 Certificates (,P7E)

™ | Include all certificates in the certification path if passible

(' Personal Information Exchange - PKCS #12 (.PFX)

...........

™ Enable strong protection (requires IE 5.0, NT 4.0 5P4 or above)

[~ Delete the private key if the export is successful

< Back I Next = I Cancel

Figure 3.20: Selecting the format to use
Enter a password and click Next (Figure 3.21).
Note:

Make sure you remember this password as you need it when importing it on the second Client
Access server.



Certificate Export Wizard

Figure 3.21: Enter a password in order to protect the private key
Now specify the path to where you want to save the .PFX file (Figure 3.22), then click Next.

Certificate Export Wizard

C:\exported_cert.pfx [

Figure 3.22: Specifying the path for the .PFX file

Finally click Finish.



Okay with the certificate exported, let’s copy it to the C: drive of the second Client Access
server, and then open the Exchange Management Shell on that server. To import the
certificate, type the following command:

Import-ExchangeCertificate —Path c:\exported_cert.pfx —Password:(Get-
Credential).password

When pressing Enter, you’ll be prompted for the password you specified earlier on as shown
Figure 3.23. It doesn’t matter what username you specify as this isn’t used in this type of
authentication.

[ N2 Inport-ExchangeCertificate ~Path c:\exported cert.pfx ~Password:<(Get (,'l-u
edential) . password

cndlet Get-Credential at command pipeline position 1 l
Supply values for the following parameters:
Credential

Please enter your credectials,

Liser name: ]ﬂ sometext

Password: [ ssseee

Figure 3.23: Importing the certificate
After clicking OK, the certificate has been imported (Figure 3.24).

# Machine: CASOZ | Scope: ehlo.dk -

[(PS] C: \>lnport-ExchangeCertificate ~Path c:\exported_cert.pfx ~Password:(Get (,'rn
edential) . password m

cndlet Get-Credential at command pipeline position 1
Supply valuez for the following paraneters:
Credential

Thunbprint Services Subject

D3D87858F9249CBFE8C3A262871D54A25CAEC3I?1B CN*mail.ehlo.dk, O=EHLO...

[PS] C:\>

Figure 3.24: Certficate imported

Now copy the certificate thumbprint to the clipboard, then enable the certificate for the

required services by typing the following command (just like we did on the first Client Access
server):



Enable-ExchangeCertificate —Thumbprint <thumbprint> -Services “IIS, POP, IMAP”

(?; Machine: CASO2 | Scope: ehlo.dk

LPS C:N2Enable~Exchange

(Ps

Figure 3.25: Enabling the SAN certificate on the second Client Access Server

The SAN certificate has now been properly enabled on both servers, and if the clients trust the
root CA from our internal Microsoft CA, we should no longer get security warnings, when
accessing OWA via the NLB cluster name as shown in Figure 3.26.
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Figure 3.26: Accessing OWA 2007 without security warnings



